Submit a question to our community and get an answer from real people.
Submit

What kind of iPod are digital booklets compatible with?

I have a 3rd generation iPod touch, and it always says the digital booklets (that come with the album off iTunes) aren't compatible with my iPod. Anyone know why or how to fix this? Thanks.

Report as

Digital booklets are compatible with iPod touch (2nd generation) and iPod touch (3rd generation). Syncing iTunes Digital Booklets requires an iPod touch with iOS 4 or later. You will need to change the media kind of your booklet. Visit http://support.apple.com/kb/ht4194# for more details.

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer
Popular Searches