Submit a question to our community and get an answer from real people.
Submit

Spore Galaxy Edition not working?

So I downloaded and installed on my Mac, but when I try to play it, it comes up with a little window thing (that I can't close out of) that says Spore. But that's it. I can't close out of it, I can't quit it, I have to restart my computer to close it. Sometimes when I try, it asks for a registration code, and so I put one in, and it goes back to the window thingy. I just want to play it but it is being stupid. My mom thinks it could be our hard drive, is that possible? I tried googling it, but it didn't help. It told me to download something else, so I did. It didn't make a difference. PLEASE HELP!!!

Report as

Ya, happened to me as we'll, and you might want to erase and reinstall it

Helpful Fun Thanks for voting Comments (2)
Report as
Tried multiple times:( Any other suggestions?
Report as
Maybe, checking if computer has viruses or malware, you can get a computer pro to check, if anything is not responding well
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer
Popular Searches