Submit a question to our community and get an answer from real people.
Submit

My 01 mazda millenia would turn over but not start one night, the next day it started right up.. Same thing happened last night . Ideas?

after the first time this happened, the next night I started it, turned the heater on, went inside for about 5 minutes and came outside and the car was not started but radio was still playing. I tried starting it and it would spun like its starting bit would not ! next day started right up.. I noticed the CEL was flashing so I took it to auto zone and I got a p0300 code .. plz help!!!

Report as

I had a similar problem like that with my 02 ranger it turned out that there was battery acid on the cables so after i undid the cables and took a toothbrush to it it started up and i no longer had any problems with it.

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...

Look up the code you received. Also check sites for common problems with your model car. That car, sorry but the engine is not reliable.

Helpful Fun Thanks for voting Comments (4)
Report as
Looked up code already. Too many different things . Just wondering if someone had a problem like this
Report as
Check the battery
Report as
Yeah, try replacing the battery. If that doesn't work it could be wiring. But be careful. Mazda's are expensive to fix. I'd recommend (if its a major problem.) getting out from under it and getting a Carrolla or an Accord. Hopefully it's just a bad battery.
Report as
Thank y'all, but could a bad battery make it turn over but not start?
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer