Submit a question to our community and get an answer from real people.
Submit

Our GE front load washer has power to the outlet but pushing the power button has no result (no lights on display)

Model WCVH6800JOMR

Report as

The GE front load washer could be having power problems if it is normally powered off while it is still in service mode. Correct this by problem by disconnecting the power for a few seconds and then reconnect it. Next, press signal, delay start then signal and delay start until it powers up.

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...

There's nothing wrong with the outlet, there's power there. Somewhere between the plug and the control panel there's probably an electical problem. You might also check the door switch. If the switch is bad, on some machines that will shut the thing down completely.

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...

Did you unplug it and check both outlets for power. Read your manual and see if it has a reset button somewhere

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...

Possibly the electrical cable is faulty? This is very likely if it's been pulled out a lot.

If you have a multimeter, check that power is getting inside the washer. Don't electrocute yourself - if this seems at all 'iffy' call the maintenance guy.

Helpful Fun Thanks for voting Comments (0)
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer
Popular Searches