Submit a question to our community and get an answer from real people.
Submit

I have an iPhone 3G and I want a game on it... And let's say if I clicked on temple run it says: " This app requires IOS 4.3."!

I need help for that!!!

Report as

Means you need to upgrade your IOS on your iPhone. Is there an update showing in your settings??

Helpful (5) Fun (1) Thanks for voting Comments (0)
Report as
Add a comment...

Have you plugged the phone into your computer and tried updating it?

Helpful (2) Fun Thanks for voting Comments (0)
Report as
Add a comment...

update it

Helpful (2) Fun Thanks for voting Comments (0)
Report as
Add a comment...

Update it if you are able to, some of the older iPhone series will not accept the newer updates, Try synching it through iTunes, and get rid of any data you do not use; the 3G doesn't have that much capacity and most newer games require a LOT!
When you decide to download a game or anything else, check your phone's available memory first, and then check the amount the App requires.
Anytime that phones memory goes below a GB, the phone will refuse to load. It ensures that you have enough memory for essentials.

Helpful (2) Fun Thanks for voting Comments (0)
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer
Popular Searches