Submit a question to our community and get an answer from real people.
Submit

Does The Sims 3 Super Patcher work on version 1.0.615?

Mine is 1.0.615, can I update to version 1.57 with Super Patcher like in this forum: http://forum.thesims3.com/jforum/posts/l... ?
I mean, I don't have to update mine to 1.0.631 or 1.27. Can I just use the Super Patcher and make it 1.57?

Report as

I dont play sims :I

Helpful Fun Thanks for voting Comments (2)
Report as
Me too. I'm installing it for my sister.
Report as
xD
Report as
Add a comment...
Do you have an answer?
Answer this question...
Did you mean?
Login or Join the Community to answer
Popular Searches